HOWTO: Recover From Network Problems

Due to XrayVision™ (XV) advanced networkability, functionality problems can occur when detrimental network errors are encountered (such as lost network connectivity). These problems can take the form of erroneous patient deletion messages, inability to save files and misplaced data. While these problems are extremely rare, repeated occurrences indicate an underlying problem with the network that should be looked into by a qualified professional.

Various data recovery methods can be employed for error and warning messages generated due to network problems. Select a topic below or scroll down for complete information:

 

Error/Warning Message: “Temporary file failure”

SUMMARY

Typically, this error message is displayed when trying to save a layout to a patient and is a result of the loss of connectivity to the networked location of the patient database.

CAUSE

Since layouts are stored in the ZIP file format, the typical saving convention is to first create a temporary file and then move the temporary file to the target filename upon successful creation of the ZIP file. Since the networking has been lost to the target computer, the initial temporary file cannot be created, thus resulting in the generation of this error message.

RESOLUTION

To save the layout, first save the file in a temporary location (usually on the local hard drive), reestablish the network connection (usually by rebooting), and then import the saved file into the patient record. To save the data:

  1. Select File > Save As from menu.

    1. Select the appropriate folder/drive from the 'Save In' drop-down list (usually, for convenience, the root directory of the “C:” drive is selected).

    2. Select the appropriate subdirectory if necessary.

    3. Enter a descriptive filename in the 'Filename' field.

    4. Click on the Save button.

  2. Close XV and reboot the computer.

  3. Start XV and reopen the patient for which the file/layout could not be saved.

  4. Select File > Open from menu. Click on the Open File Direct button. The 'Open' dialog box displays.

    1. Select the appropriate folder/drive from the 'Look In' drop-down list (the one that previously selected when saving the file).

    2. Click on the Open button.

  5. The 'Move Files To Patient' dialog box displays.

    1. Enable the On successful move, delete original file option.

    2. Click on the Yes, add these files to the patient button.

  6. The 'Extended Image Information dialog box displays. Associate the appropriate 'Image Type', 'Image Subtype', and then click on Done.

 

Error/Warning Message: “Someone has just deleted or merged the patient …”

SUMMARY

The following error regarding deleted/merged patient is display in XrayVision™ (XV):

CAUSE

This error message is displayed when working with a patient and is a result of either the patient being deleted, merged, or the loss of connectivity to the networked location of the patient database.

Network connectivity loss interferes with XV's ability to check the status of open patients with the patient database.   Depending on when the network connectivity is lost, XV can sometimes be fooled by the operating system into believing that the indicated patient has been removed from the patient database.

Resolution

Follow the steps below if the issue is a result of loss of network connectivity.

  1. SAVING a NEW SINGLE IMAGE
  2. Steps below must be performed BEFORE clicking on the OK button on the 'Patient Deletion Warning' dialog box.

    To save a single image that has just been captured:

    1. Go to one of the other image capture workstations on the network.

    2. Start the XV application.

    3. Open the patient for whom the warning message is displayed on the other computer.

    4. Select File > Open from menu. Click on the Open File Direct button. The 'Open' dialog box displays.

      1. Select the server on which the XVa3 application is installed.

      2. Navigate to the main XV application directory on your server.

      3. Double-click on the /SafetyCache/ subdirectory.

      4. Double-click on the subdirectory named after the computer on which you received the warning message.

      5. Select all of the files listed.

      6. Click on the Open button.

    5. The 'Move Files To Patient' dialog box displays.

      1. Enable the On successful move, delete original file option.

      2. Click on the Yes, add these files to the patient button.

    6. The 'Extended Image Information dialog box displays. Associate the appropriate 'Image Type', 'Image Subtype', and then click on Done.

    7. Go back to the computer displaying the warning message, close XV and reboot the computer.

  3. SAVING a NEW LAYOUT
  4. Steps below must be performed BEFORE clicking on the OK button on the 'Patient Deletion Warning' dialog box.

    To save a layout that has just been captured:

    1. On the same computer on which the error message is displayed, select Windows Explorer from the Programs option in the Start menu.

    2. Using Windows Explorer, navigate to your temporary directory (usually “C:\Windows\Temp”).

    3. Double click on the /XVAWorkInProgress/ subdirectory.

    4. Drag all of the subdirectories to a temporary location (usually your desktop). (Do not leave them in the /XVAWorkInProgress/ directory for they will automatically be deleted.)

    5. Click on the OK button, close down XV and reboot the computer.

    6. Once the computer has rebooted, restart the XV application.

    7. Perform the following steps for each of the subdirectories that you copied/moved out of the /XVAWorkInProgress/ directory:

      1. Select File > Acquire > Capture Layout Images from the menu.

      2. Select any style of layout (it will be replaced shortly).

      3. Select Group > Display As > Grid View from the menu.

      4. Drag-and-drop the files contained in the subdirectory onto one of the cells in the grid within XV.

      5. Select Group > Display As > Layout View from menu.

      6. Select Group > Layout Options > Associate Layout the menu.

      7. Select the appropriate layout that should be used with these images.

      8. Select File > Save from the menu.

    8. Delete the directories that were copied/moved out of the /XVAWorkInProgress/ subdirectory.

Application Crashes on Power Suspend

SUMMARY

The XV crashes when either the current computer or server goes into power suspend mode.

CAUSE

When a computer’s hard drive is powered down during suspend mode, vital resources on that hard drive can not be accessed (DLLs, windows components, databases, etc.). Usually, when Windows finds vital resources inaccessible it kills off the offending application or process (usually ending in a crash since Window’s itself cannot free its own resources thus resulting in an abnormal termination).

RESOLUTION

Turn off the power suspend features of both the client computers and the server.

MORE INFORMATION

Please refer the system documentation that came with the computer concerning suspend mode operation.